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1. Getting Started

1.1 What is Navigator

NAViGaTOR - Network Analysis, Visualization, & Graphing TORonto is a software system for
scaleable visualizing and analyzing networks.

The current version, NAViGaTOR 3, increases modularity, improves scaleability, extends in-
put/output options, brings new network views and analysis algorithms.

Directed and undirected networks can be annotated by relevant online databases or local data
sets, and analyzed by diverse algorithms, which in turn enable enrichemnt analysis and discovering
relationship between network structure and function. In particular Gene Ontology, protein-protein
interaction and pahtway databases, and Human Disease Ontology are supported.

NAViGaTOR is an academic project under active development by members of Jurisica Lab of
the Krembil Research Institute. The project has been funded by multiple grants, including Genome
Canada, Ontario Research Fund - GL2, to extend its functionality and enhance data interchangeability
with other tools (e.g. Cytoscape) for network analysis and visualization. Therefore, Navigator
implements import and export functionality for the most common file formats, such as XGMML,
PSI or text.

NAViGaTOR is freely available to academic research under the GNU General Public License
(https://www.gnu.org/licenses/gpl-3.0.en.html).

1.2 Installation

1.2.1 System Requirements

– You must have downloaded and installed Java Runtime Environmemt (JRE) 8 to your computer in
order to run the program.

– In order for the application to start and run properly, your machine must have the required Visual
C++ runtime libraries. They can be installed here: https://www.microsoft.com/en-us/
download/details.aspx?id=30679

https://www.microsoft.com/en- us/download/details.aspx?id= 30679
https://www.microsoft.com/en- us/download/details.aspx?id= 30679
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– If there is an issue with file permissions in Windows versions, install the application in your user
folder (rather than under C:Program Files), or run it as an administrator.

1.2.2 Windows
1. Download Navigator onto your Microsoft Windows system.
2. Open the downloads folder and run the program
3. Wait for Navigator setup wizard to open and click "next"
4. Select the folder in which you want Navigator to be installed
5. Select the start menu folder in which you want set up to create the program’s shortcuts
6. NOTE: Please run the software as administrator, by right click "Run as administrator".

1.2.3 Linux
1. Download Navigator onto your Linux system.
2. Open the Terminal and go to the download folder.
3. Start the installation via:

$ chmod +x NAViGaTOR_...-sh
$ sudo NAViGaTOR_...-sh

4. Follow the instructions in the opened installation window.
5. Chose the installation and symbolic links folder.
6. Click "Next" and wait until installation finished.
7. Switch to the installation folder.
8. Use the following command to start NAViGaTOR.

$ chmod +x navigator
$ ./navigator

1.3 Basic Introduction to Graph Theory
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A network is an abstract conceptual model of a definite set of
entities (e.g., humans, proteins, metabolites, neurons, species or
non-biological objects such as cars or books), and the relation-
ships between those entities (i.e., interactions among proteins
in a protein protein interaction network or humans in a social
network). In computer science and mathematics, a network is
often referred to as a graph. Formally, the set of entities we
seek to represent are the set of nodes in a graph, where the set
of edges defines pair-wise relationships between members of
nodes.

Objects such as proteins, genes, or humans can be repre-
sented by nodes, while their interactions, for instance, biolog-
ical reactions, gene regulation, or the social interactions are
represented by edges. In the example on the right side, the
network visualizes the social interactions in a group of friends.
Each person is depicted as node and the edges represents an
interaction such as "friends with". This representation allows the analysis of structural features of a
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network and reveals key components, for example, genes connected to certain cellular or disease
mechanisms or highly connected influencers in a social network. It also allows one to apply a number
of visualization techniques that enable the user to visually explore the data.

1.4 Creating a Network

To create a simple network, select menu File → New..., and select between an Empty graph or
a Random graph. For more details on creating a manual network, see Section1.4.2, while for a
random graph see Section1.4.3.

1.4.1 Node and Edge Types

In Navigator, Nodes and Edges have a specified type. A Type is a named category to which a node
or edge belongs. For example, in a social network graph, a node could be of the type ’Person’ while
an edge could be ’Knows’. In a transportation network, nodes could be of the types ’City’ or ’Town’
while edges could be ’Road’ or ’Railway’. By default, most nodes are set to the default type ’Node’
and edges to the default type ’Edge’ in Navigator, but very complex graphs and analyses can be
produced by using multiple types instead of the default settings.

1.4.1.1 Node Types

A graph can contain different Types of nodes, for instance metabolites and enzymes that are
processing them. In a network representing the structures of a company, node types can represent the
different functions, such as sales representatives, IT-consultants, or engineers. Nodes can exist on
their own or be connected by edges, and can have attributes associated with them. It can be created
via Graph → New Node Type ....

1.4.1.2 Edge Types

Edge Types can reflect different categories of interactions. Each edge is connecting a source node
and a target node. Variations for protein protein interactions are for instance the covalent binding
of proteins in a complex or regulatory activity or the enhancing influence of an enzyme. It can be
created via Graph → New Edge Type ....

Functionally, edges can behave in different ways:
– Directed Edges allow traversal in one direction only; from source to target. This is relevant to

algorithms and searches for which directionality is needed.
– Undirected Edges do not make a distinction when algorithms encounter them; the edge can be

traversed from source to target or from target to source. Edges that are not explicitly Directed
Edges are Undirected.

– Restricted Edges are edges that can only exist between specific types of nodes. This can be
used to enforce rules when creating graphs.
Edges created with the ‘neighbors’ option maintain indexes of their nodes, allowing for faster
traversals and searches. Like nodes, edges can have attributes associated with them.

1.4.2 Manual Creation of Networks

Before creating a new Network, an empty network file has to be
created, using the Menu File → New... → Empty Graph.
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1.4.2.1 Create New Node
Adding a new Node to an open graph can be done by selecting menu
Graph → New Node. If no Object Type is defined for nodes in the
graph, you will be prompted to create one. Ensure that the name
you use for your type is unique and descriptive.
When an Object Type is available, you can select it from the Add
New Node dialogue, and a new node with that type will be created
in the graph.

1.4.2.2 Create New Edge
Adding a new Edge to an open graph can be done by selecting the nodes you wish to connect and

selecting Graph → New Edge. The message box that opens, re-
quires to specify the type of edge you want to create and which
nodes you want to connect with an edge. E.g. in the given example
we want to create an edge from node 1024 to 1034. Therefore the
square connecting the two is checked.
If no Object Type is defined for edges in the graph, you will be
prompted to create one. Ensure that the name you use for your type
is unique and descriptive, and refer to the documentation above for
the significance of each setting. When an Object Type is available,
you can select it from the Add New Edge dialog. A matrix will
be generated that allows you to specify the source and targets for
the edges to be generated. By default, all nodes will be identified
by their OID, but this can easily be toggled to a more meaningful

attribute by using the Label Source combo box.

1.4.2.3 Remove Node
To remove one or several nodes, one can select the nodes and use the menu sequence Edit → Delete
Nodes.

1.4.2.4 Remove Edge
To remove one or several edges, one can select the edges and use the menu sequence Edit → Delete
Edges.

1.4.3 Create Random Network
To create a new random network, please use the menu sequence File → New... → Random Graph.
When creating a random graph, a box will pop up allowing you to set a name for the new graph,
select the type of random network and select the desired number of nodes and edges.

The following types of random networks are available:
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Random Graph Randomly created nodes and randomly assigned edges.
Random Tree Graph Randomly created tree-like graph. A tree-like graph does not have any

cycles.
Complete Graph Randomly generated nodes, where each node is connected to each other node.
Random Directed Acyclic Graph Randomly generated nodes connected by directed edges. Again

this algorithm ensures that the graph does not have any cycles.
Random Connected Graph Random graph as created by "Random Graph", with an additional

requirement that all nodes belong to one connected component. That means, there is a path
from each node to each other node.

1.5 Basic Network Handling
After creating a new network, it will be visible in the "Graph View" panel. The default graph layout
in NAViGaTOR is the GRIP layout, see Chapter 4 "Network Visualization" for more details.

In the following we will describe a few basic functions in the NAViGaTOR graph view:
A Selection Tool: Use this tool to select single elements or objects. A mouse click on the targeted

element selects it. The "Ctrl"-Key enables the selection of several elements.
B Lasso Tool: Use this tool to select a group of elements or objects. Draw a circle around the

targeted elements.
C Move: Use this tool to move a selection of elements or the entire network.
D Scaling: Use this tool to scale a selection of elements or the entire network.
E Rotation: Use this tool to rotate a selection of elements or the entire network.
F Navigate: Use this tool to navigate through large networks.

1.6 Basic Network Coloring
The appearance of each component in the network (nodes, edges, node labels and edge labels) can
be adjusted. The appearance panel provides different "Renderer" change attributes such as color or
shape. Note: To manipulate the following features, ensure you select the objects in the network you
wish to work on.
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Color Change color of the node or edge respectively.
Opacity Change the opacity of the edge.
Node Shape Change the shape of the node.

Height Change the height of the node.
Width Change the width of the node.

Edge Width Set the width of the edge.
Curve Select the type of curvature of the edge.
Stipple Plot the edge as a dashed line.

To change node and edge labels, the "Basic Label Renderer" is required. Here you can change for
instance:

Source Set the Variable shown as label.
Length Limit Select the Label size limit.
Foreground Color Change color of the node or edge label.
Opacity Change the opacity of the node or edge label.
Background Color Change color of the background of the node or

edge label.
Opacity Change the opacity of the background of the node or edge

label.

1.7 Open Network
Opening a file in Navigator will create a new graph in the Workspace. Every file format has unique
features and advantages. Here we give an overview of different file types supported by Navigator.
Plain Text Files Navigator is able to open any tab-delimited plain text file. A userfriendly wizard

is guiding the user through the extraction of edges, source and target nodes, as well as their
attributes. You can find a detailed description of the process in Section 2.2.3.

Network Files Specialized files dedicated to store all information required to mirror a network.
Popular file formats supported by Navigator are XGMML, XML and PSI. You can find a
detailed description of these formats in Section 2.

A listing of the all the formats and important information on their usage can be found below in
Chapter2.

1.8 Save Network
In order to save or export information and analysis results from Navigator, a network can be stored
in different file formats. The following list gives an overview of different export types supported by
Navigator.
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Text Information about the nodes, edges and subsets as well as the corresponding annotations and
analysis results can be exported as tab deminited text files. This enables easy export to further
analysis.

Network Files Specialized files dedicated to store all information required to mirror a network.
Popular file formats supported by Navigator are XGMML, XML and PSI You can find a
detailed description of these formats in Section 2.

Figures Visualizations of the network and visual analysis results can be exported as image file such
as BMP, GIF, JPG, PNG, SVG, TIF file. SVG is a vector graphics file format that can be
handled by most modern graphical tools, such as Inkscape or Photoshop.

1.9 Subsets

1.9.1 Create Subsets

A network can be partitioned into sub-networks or sub-graphs. These can be used to structure a net-
work. In NAViGATOR these partitions are called subsets. In the following we describe how to create
them.

– Select the "Subsets" panel in the bottom part of the application.
– Select the nodes you want to combine into a partition.
– Chose the "Cross"-Botton in the "Subsets" panel.
– Enter the required fields:

– Parent Type
– Subset Name

– Click "Create"
The subset will appear in the subset panel, see section1.9.4, Subset
Visualization.

1.9.2 Edit Subset & Select Subset

A subset can be edited by adding nodes or replacing the whole subset
by a new set of nodes. Open the "Arrow menu" and use "Add to Subset"
or "Replace Subset" to add or replace nodes in a subset, respectively.
The same menu is used to add nodes to a existing selection, "Add to
Selection", or replace a current selection and selecting the nodes in the
subset, "Replace Selection".

1.9.3 Hide Subset

Nodes also called here also Children and Parents the objects that represent
the subset in the graph can be set to invisible by using the "Eye" menu:
Select a subset and use the menu to hide or show "All", all "Children"
or all "Parents" of a sub-network.

1.9.4 Subset Visualization

The following figures shows the subset panels in the bottom of the NAV-
iGATOR framework: Subsets, Intersections and Nodes.
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Subsets Intersections Nodes

The first panel on the left
shows a list of all subsets cre-
ated for this,network includ-
ing attached attributes, such
as ID, type or name.

The middle panel shows the num-
ber of nodes, objects and the sum,
for all,selected subset (left panel)
and intersections of these. The
centre, shows bar plots for both
nodes and edges in randomly as-
signed colours.

The right panel shows the list
of nodes that are member of
the selected subsets. Each
node is coloured according to
the corresponding subset or
subset intersection.

1.9.5 Snapshots View
The snapshot panel shows color coded representations of the children of the subsets that are presently
selected in the subset table.

1.9.6 Collapse Subsets
In Navigator, subsets can collapsed into multi-nodes, representing the group or subset. An example
usage for this functionality is the representation of protein protein complexes and their connections
in a protein protein interaction network. To collapse a subset do the following steps:

– Go to the "Graph Panel".
– Move the mouse into the panel and click right mouse button. The context menu opens.
– Select Visibility and Collapse, which shows a list of all Subsets.
– Select the subset to be collapsed.

1.9.7 Delete Subset
– Select the "Subsets" panel in the bottom part of the application.
– Select the subset to delete
– Chose the "Pen"-drop-down menu and select "Delete Subset".



2. Import, Export and Integration

Description of how data can be imported to and exported from Navigator, as well as which data
formats are supported.

2.1 Data Model
The database backbone of the application is Sparksee graph database. In Sparksee, there can be
multiple types of basic network types - nodes and edges. Multiple edges between two nodes are
allowed, as well as loops (with the same node on both ends of the edge). Edges could be either
directional or non-directional. Edge types can be set to be allowed to link only nodes of specific types.
The data is stored as object attribute. Attributes are type-specific. Global type attributes can carry
values for network objects, nodes and edges, regardless of their type. The data Types supported are
Boolean, Integer, Long, Double, Timestamp, String, Text and OID. Attributes can be set to be unique
and indexed. For more detailed description of Sparksee’s data model, see General Concepts chapter
of Sparksee User Manual at http://www.sparsity-technologies.com/UserManual/GraphDatabase.html
For performance and flexibility reasons data model in NAViGaTOR 3 is extended by Graph Data
objects. The data types that are supported by graph data are plugin specific and might have different
ways to access and visualize information within.

2.1.1 Attributes Description
Attributes are values that are associated with Graph Objects. An attribute can either be Global
(applying to all nodes and edges) or can be associated with a single type. For example, a node type
called ‘Protein’ can have an associated attribute called ‘UniProt ID’. If the graph contains another
type called ‘Gene’, nodes of the ‘Gene’ type will not contain ‘UniProt ID’ attributes. If there is a
global attribute called ‘ID’, both ‘Protein’ and ‘Gene’ nodes will have the ‘ID’ attribute.
The following list describes all possible attribute types:
Boolean A Boolean is a binary variable that can be either "TRUE" or "FALSE".
Integer Numeric variable that can represent discrete numbers (a 32-bit whole number, can be up to

231 digits long).
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Long Numeric variable that can represent discrete numbers (a 64-bit whole number, can be up to
263 digits long).

Double Numeric variable that can represent continuous numbers (floating-point decimal, minimum
value = 4.9E-324, maximum value = 1.7976931348623157E308).

Timestamp Variable that represents dates or times. Required for time series data. It works properly
with timestamps in the range ’1970-01-01 00:00:01’ UTC - ’2038-01-19 03:14:07’ UTC.

String Variable that can store short text’s or words (up to 2048 characters). Optimal for attributes
like categories.

Text Variable that can store long texts (up to and beyond 2048 characters).
OID Object Identifier for Graph Objects.

In addition, attributes can have different features:
– Unique attributes have a unique value for every object they apply to. Two nodes, or two edges

cannot have unique attributes with the same value.
– Basic attributes have no restrictions.
– Indexed attributes have no restrictions, but are special in that the graph database creates a

fast-lookup table to make searching for them faster, at the expense of memory resources

2.2 Read Network from file

2.2.1 BioPAX Level 3 (.owl, .xml)

Biological Pathway Data (BioPAX) is a community standard data exchange format designed to enable
integration, exchange, visualization and analysis of biological pathway data. Within NAViGaTOR,
physical entities as well as some of the logical constructs of BioPAX are represented as nodes, but at
the present time there is no 1:1 correlation between BioPAX and NAViGaTOR objects appearance.

BioPAX files can be loaded into NAViGaTOR using File -> Open. You must choose the
"BioPAX Level 3 (.owl, .xml)" for file type.

For more information about the BioPAX file format, please visit http://www.biopax.org/.

2.2.2 DEX and DEX backup

DEX is the standard format of Sparksee (formerly known as DEX), NAViGaTOR’s backbone. A
DEX graph contains nodes and edges assigned to types (labels), supports directed and multiple edges
and includes nodes and edges attributes.To open a file saved with this format, select File -> Open
and choose DEX (.dex) or DEX backup (.dexb).

2.2.3 Import Tab-delimited file

Delimited Text Files are plain ASCII files in a row/column format, with a reserved character for
separating columns. This file type is easily exportable from most spreadsheet programs, and many
databases export ’flat’ files of their data that can either be loaded in this format or translated to it.
Data from Delimited Text Files can include graph objects and attributes, but does not support the
creation of complex data structures such as XML. Each row defines a graph object or objects using
columns in the row to identify objects and specify attribute values.

When you specify Delimited Text File as your file type and select a file from the Open dialog,
you will be presented with a wizard interface, which will present you with a preview of the file, and
options on how the file’s rows and columns are to be interpreted.

http://www.biopax.org/
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– Import the Tab-delimited file via the Navigator menu File-> Import, select a file and Click
“Next”.

– Set header size to 1 and click “Next”. Delimited text files often contain header rows, which
describe the data in some way, but should not be loaded as data themselves. We can here
specify the size of the header in rows, as well as to indicate a Title Row, which contains the
names of each column generated. Though a Title Row doesn’t need to be specified, it can be
useful to automate some of the later steps in file loading. The Title Row will be indicated in
the Data Preview panel by its darker blue color.

– For every imported tab-delimited file, two columns must be specified, whose contents indicate
the unique ID’s of the nodes. Each row defines an edge to join two nodes. Use the drop down
fields above the columns to annotate the starting node as source index and the partner node as
target index. The boxes (here indicated by A, B, and C) Enable the user to define node and
edge Type. If the source and target nodes do not have the same type, remove the check from
the "Same as source" field in box C and enter the required information. Click “Next”.

– If required for further analysis, attributes that are stored in the file can be associated to the
source node, the target node or the edges. Each column corresponds to one attribute. Besides
the corresponding type for each associated column we need to define the type of information
(Text, numeric etc. ) and whether it is a basic, indexed or unique variable.

– Finally, we need to manually define a unique name for each attribute or column. Alternatively,
you can click the “Copy Title Line” to automatically fill the names. Note, the names have to
be unique. Click “Next” to create the network.
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The same procedure can be used to add nodes and/or edges to a pre-existing network.

2.2.4 GraphML

GraphML is an XML-based file format for graphs, used as a common format for exchanging graph
structure data. It supports directed and undirected graphs as well as nodes and edges specific
attributes. For more information on this file format, visit http://graphml.graphdrawing.org/.
To open a graph in this format, use File -> Open and choose the "GraphML (.graphml, .xml)" file
type.

2.2.5 KGML

The KEGG Markup Language (KGML) is the standard format used by KEGG PATHWAY database
http://www.genome.jp/kegg/pathway.html. To open a file in this format use File -> Open
and choose the "KGML File (.kgml, .xml)" type.

2.2.6 NAViGaTOR

NAViGaTOR’s native format. Version 3 saves files with .n3e extension, but there is full compatibility
with files generated using NAViGaTOR 2.x. To open a NAViGaTOR file, use File -> Open and
choose either "N3E (.n3e)" - for files generated using NAViGaTOR 3 - or "NAViGaTOR 2.x XML
(.xml)" - for files generated with any version of NAViGaTOR 2 - file type.

2.2.7 OBO

The Open Biological and Biomedical Ontology (OBO) is a file format designed to represent ontolo-
gies in a logically well-formed and scientifically accurate way. The ontology most frequently used
in biology is Gene Ontology (GO). To open a file in this format, use File -> Open and choose the
"OBO ontology (.obo)" file type.

2.2.8 PSI-MI Format

The Proteomics Standards Initiative - Molecular Interaction, (PSI-MI), is a community standard data
exchange format for representing molecular interactions. For more information about the PSI-MI
file format, please visit http://www.psidev.info/index.php?q=node/60. PSI-MI files can be
loaded into NAViGaTOR using File -> Open and choosing the "PSI-MI (.xml)" file type.

2.2.9 SBML

Systems Biology Markup Language (SBML) was created as a language to describe biochemical
reactions, describing it in a format exchangeable between different software packages. More
information on SBML are available at http://sbml.org/documents/. To open a SBML file, use
File -> Open and choose the "SBML (.sbml,.xml)" file type.

2.2.10 XGMML

eXtensible Graph Markup and Modelling Language (XGMML) is an XML based format used for
graph description. More info on XGMML file format is available at http://cgi5.cs.rpi.edu/
research/groups/pb/punin/public_html/XGMML/. To open a XGMML file, use File -> Open
and choose the "XGMML (.xgmml,.xml)" file type.

http://graphml.graphdrawing.org/
http://www.genome.jp/kegg/pathway.html
http://www.psidev.info/index.php?q=node/60
http://sbml.org/documents/
http://cgi5.cs.rpi.edu/research/groups/pb/punin/public_html/XGMML/
http://cgi5.cs.rpi.edu/research/groups/pb/punin/public_html/XGMML/
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2.2.11 Import Network from Database

2.2.11.1 BioModels

BioModels is a central repository of mathematical
models of biological/biomedical processes. Mod-
els described from literature are manually curated
and enriched with cross-references. To know more
about BioModels refer to https://www.ebi.ac.
uk/biomodels-main/.
To upload a network from BioModels, select
Database -> BioModels. A dialog window will
open, where any model present in BioModels can
be searched (using Category to select the type of
search, and Filter text to perform the search) and
retrieved. To upload the model of interest select the
Matching model and click open.

2.2.11.2 KEGG

KEGG PATHWAY is a collection of manually drawn pathway maps including molecular interac-
tions, reactions and relation networks. Specific details about KEGG query can be found at http:
//www.kegg.jp/kegg/rest/keggapi.html. To upload a network from KEGG PATHWAYS,
select Database -> KEGG. A dialog window will open, where there are three possible searches:

– Build network from pathway. It allows
to import a pathway in NAViGaTOR from
KEGG PATHWAY. The user can select
any pathway from the ontology tree, and
after specifying the organism, clicking
execute the pathway will be imported in
NAViGaTOR. This works only for the
lowest level of the ontology.

– Create subsets from pathways. It al-
lows to select a pathway from KEGG
PATHWAY and to import it as a subset
in the network. The user can select the
pathway from the ontology tree on the
left, and then select the organism, the
pathway node type, the node type and
what ID to map to the node attribute.
Execute will import the pathway in NAV-
iGaTOR.

– Download conversion map. Using this
function it is possible to download two
plain text files: UniProt to HSA and
HSA to UniProt conversion maps, that
map any KEGG ID to or from UniProt.

https://www.ebi.ac.uk/biomodels-main/
https://www.ebi.ac.uk/biomodels-main/
http://www.kegg.jp/kegg/rest/keggapi.html
http://www.kegg.jp/kegg/rest/keggapi.html
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2.3 Import data to Network
2.3.1 Delimited text

Importing data from a Tab-delimited file is very similar to reading a network from a text file. File
formats included are .txt, .csv, .tab, .tsv. To import data, select File -> Import and then delimited
text. This page allows your to specify the way in which your CSV data is loaded. Locale : The
default locale (.utf8) will apply to most files, however, other formats are available as specified by
the Data Import section of the Sparksee Manual. Delimiter : From here, you can select the ASCII
character used to separate each row into columns (for example, horizontal tab, line feed...). Quote :
For text or string type data, the column can be enclosed in quotations to ensure that characters in the
column are not mistaken for delimiters. Any characters typed in this field will be used as quotes by
the file loader.

Set Header Information, as above.
Set Node ID Columns : The attribute will be used as node or edge identifier to associate data

being imported to the specified graph entity.

Set Attribute Import Columns : For each column, you can specify what object that column refers
to (Source, Target, or Edge), and define the Attribute you wish to use to represent that column.
Ensure that the names you choose are unique and adequately describe the data in that column. If you
previously selected a Title Row, you can automatically name each activated column (coloured green,
after any type aside from None is selected) using the content of that row.
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2.3.1.1 Delimited Text Subset File (.txt, .csv, .tab)

To automatically import subsets, the text file must include
at least two columns, one that lists the name of the subset
and one that lists the elements of the subset (it is important
that the ID used for the elements of the subset coincide
with an ID or annotation used for the elements of network).
Moreover, the character used to separate the two columns
must be different from the one used to separate the subsets
elements.

Once the file is correctly setup, select Import ->
Delimited Text Subset File (.txt, .csv, .tab) and in the
dialog window specify the primary delimiter (between
columns) and the secondary delimiter (among elements),
and click next.

Set then header information, as above, and click next.
Finally, select a column for parent index (name of the
subset) and child index (elements of the subset), and click
done. The subsets will be automatically imported and
created accordingly.

2.3.1.2 Serial Data Table (.txt, .csv, .tab)

This type of data is used to import repeated attributes for the same elements (for example, gene
expression at different time points for each node). The text file for this task needs to be setup such as
the first column of the file contains the series key (for example time points), while each consecutive
column include data for each element (for example node). Columns headers have to include an
attribute matching the attribute of the element in the network the data need to be assigned to. Once
the file is correctly setup, select Import -> Serial Data Table (.txt, .csv, .tab) and a dialog window
will open. In the window, select the column separator character, the header and title size, the key
and value data type, to which object the values need to be assigned (object type), using which
attributes (ID attribute). It is also possible to select "open output view" to see the imported data
right away. Once clicked Import, serial data will be automatically imported.
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2.4 Divide and Merge Networks
2.4.1 Copy Sub-Networks

Copying a network or part of it:
– Mark the nodes and edges of interest
– Use the right click menu on one of the nodes and

select "Edit"-> "Copy"
– Go the network file of interest (or create a new

empty file).
– Use the right click menu and select "Edit"->

"Paste".
– A popup opens and requires you specify the at-

tributes to be copied to the new network (see right
side).

– For better visibility, we apply GRIP layout, set the
colour of the nodes to blue and activate the node labels.
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2.4.2 Merge Networks

Merging two networks:

– Mark the nodes and edges of interest.
– Use the right click menu on one of the nodes and

select "Edit"-> "Copy"
– Go the network file of you want to merge it with.
– Use the right click menu and select "Edit"-> "Paste"
– A popup opens and requires you match the attributes

names of the copied network to the attribute names
given network (See top right side).

– For better visibility, we apply GRID layout, set the
color of the nodes to blue and activate the node
labels.

– Finally, you need to merge the networks by using
the right click menu and select "Edit"-> "Merge".

– Define the identifier to be used for the merging
process (See bottom right side).
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2.5 Export Networks

2.5.1 Image Export

You can export images from the Graph View in several formats. The preferred format for publication
is SVG, as it is infinitely scalable and high-quality. For info on the SVG format, visit http:
//www.w3.org/Graphics/SVG/. However, for very large or graphically complex graphs, exported
SVG files may be too large to edit or display in some software. In these cases, the following
bitmap formats are available, which will export the graph View exactly as it appears on your screen:
BMP, JPG, TIF, PNG, GIF. To export an image from a Graph View, first ensure that you have the
Appearance Tab open in your Workspace. Once you have clicked on the graph view you wish to
export, the Appearance Tab should show you the renderers in that view. From here, you can click
on the camera icon to open a save dialog. Select your file format and name, and click on ’Save’ to
export the file.

2.5.2 Data Export

It is possible to export any data included as a table in NAViGaTOR.
Right clicking on the table to be exported, select export and then
choose among: selection to clipboard, where anything selected is
copied to be pasted in any other text handling program, table to
clipboard, where the entire table of interest is copied to be pasted
in another program (note, if the table is very big, this command might take some time), and table to
file, that opens a dialog window where the user can name the file and decide the location where to
save it.

2.5.3 Whole Network Export

Note: some formats are repeated from Section2.3

2.5.3.1 NAViGaTOR Format

When a graph is saved in .n3e format, it can be assumed that all information in the workspace
pertaining to that graph will be saved, and can later be loaded into the workspace again without any
losses. To save a network in NAViGaTOR format, select Save (if the first time) or Save As, and in
the dialog window choose N3E .n3e, name the network and save it to a destination of choice.

http://www.w3.org/Graphics/SVG/
http://www.w3.org/Graphics/SVG/
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2.5.3.2 DEX and DEX backup
DEX is the standard format of Sparksee (formerly known as DEX), NAViGaTOR’s backbone. A
network exported in this format will include nodes, edges and attributes, but not visual annotation or
dynamic attributes. To save a network in DEX format, select Save (if the first time) or Save As, and
in the dialog window choose DEX (.dex) or DEX Backup (.dexb), name the network and save it to
a destination of choice.

2.5.3.3 GraphML
GraphML is an XML-based file format for graphs, used as a common format for exchanging graph
structure data. For more information on this file format, visit http://graphml.graphdrawing.
org/. When saving on this format, only nodes/edges will be saved without any other feature. To
save a network in GraphML format, select Save (if the first time) or Save As, and in the dialog
window choose GraphML, (.gml, .xml), name the network and save it to a destination of choice.

2.5.3.4 XGMML
XGMML is an XML based format used for graph description. More info on XGMML file
format is available at http://cgi5.cs.rpi.edu/research/groups/pb/punin/public_html/
XGMML/. When saving on this format, nodes, edges and attributes will be saved, but not visual
annotations or dynamic attributes. To save a network in XGMML format, select Save (if the first
time) or Save As, and in the dialog window choose XGMML (.xgmml, .xml), name the network
and save it to a destination of choice.

2.5.3.5 Delimited text
Tab-delimited files are plain ASCII files in a row/column format, with a reserved character for
separating columns. As such, when saving a network in this format, only information about which
nodes interact will be saved. On re-opening the network, no automatic upload will be performed
and user will have to perform the same process as described in 2.2.3. To save a network in text
format, select Save (if the first time) or Save As, and in the dialog window choose Delimited text
(.txt, .csv., .tab, .tsv), name the network and save it to a destination of choice.

http://graphml.graphdrawing.org/
http://graphml.graphdrawing.org/
http://cgi5.cs.rpi.edu/research/groups/pb/punin/public_html/XGMML/
http://cgi5.cs.rpi.edu/research/groups/pb/punin/public_html/XGMML/




3. Network Annotation

The visualization of large biological networks often results in an incomprehensible ‘hairball’, which
is not directly interpretable. Therefore, it may be difficult to interpret and extract useful information
with respect to biological meaning.

The integration of additional information about the entities represented in the network, may
facilitate the organization and the analysis of the networks. These node or edge annotations can be
included in the original data, such as network files, or imported from additional files or databases,
see Chapter 2. We can categorize network annotation according to the type of data, quantitative and
qualitative, respectively.

Qualitative annotations

Qualitative annotations can be visualized through qualitative visual attributes, such as colour, size,
outline, and shape. Widely used sets of annotations are available from public biomedical databases
and ontologies. An ontology formally names and defines the terms, properties, and relationships
among the entities that exist in a particular domain. See Section 3.3 for examples.

Quantitative annotations

In contrast to qualitative information, quantitative annotations rely on continuous measures, that are
determined analytically, calculated, or estimated by different techniques. Many databases collect
quantitative data that can be used to annotate nodes, e.g., GEO (https://www.ncbi.nlm.nih.
gov/geo/, ArrayExpress (https://www.ebi.ac.uk/arrayexpress/, The Protein Atlas (http:
//www.proteinatlas.org/, while very few databases include data that can be used to annotate
edges - one example being COEXPRESdb (http://coxpresdb.jp/.Quantitative measures can be
visualized through quantitative visual attributes such as size (node type and outline), transparency, or
shades of colors

https://www.ncbi.nlm.nih.gov/geo/
https://www.ncbi.nlm.nih.gov/geo/
https://www.ebi.ac.uk/arrayexpress/
http://www.proteinatlas.org/
http://www.proteinatlas.org/
http://coxpresdb.jp/
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3.1 Manual Annotation
3.1.1 Adding a New Attribute

Select Graph -> New Attribute. Name the attribute in the "New Attribute Name" box. You can select
an object type, value type, and constraints using the drop down menus for each. To use a default
value, select the "use default value" box and manually enter the value.

3.1.2 Add Node Labels
Ensure you have highlighted the desired portion of the graph. Under the "basic label renderer" drop
down, you can add and modify node labels. When selecting a source, you can choose from any of
your created attributes, or "index" or "none" using the drop down menu. If you wish to add a length
limit, deselect the "none" box and choose a numerical value with the up/down arrows. Foreground
and background color and opacity can be modified using the respective scales. To reset colors,
click "auto color". Label size, horizontal justify, vertical justify, and distance can be modified using
the respective scales and drop down menus. By selecting only the "angled" box, you can modify
the anchor point by dragging your cursor around the anchor point circle. From the anchor point,
you can adjust by an increase or decrease of up to 10 units. Click "flip" to make the anchor point
diametrically opposed. To center the anchor point, simply check the "center" box.

If selected, the same procedure will add labels to subset parent nodes as well.

3.1.3 Add Edge Labels
Ensure you have highlighted the desired portion of the graph. Follow the same instructions that
apply to adding node labels, with the exception of angling and anchor point.

3.2 Annotation by File
This has already been described in Chapter 2 (importing data to network from tab separated file)

3.3 Annotation by Database
3.3.1 PathDIP

Click Database -> PathDIP Enrichment. Select a node type and node index attribute using the
respective drop down menus. For the node ID entry, you can select between using the full graph or
using graph selection by selecting the desired box. Choose an ID type from the drop down menu
and select all the desired data sets. Choose a result node type, result name attribute, result source
attribute and result P value attribute. Click search to view results. Then choose a max P-value to
filter by using the up/down arrows and select the pathway(s) you wish to add. Pathways will be
added as subsets.

3.3.2 Integrated Interaction Database (IID) Interactions
To complete an IID Protein-Protein search, select Database -> IID Interactions. Choose a node
and edge type using the drop down menus. For a new edge or node type, it is possible to rename the
output attribute. Select a node Query ID attribute and edge source attribute using the respective
drop down menus. By clicking "manual entry" you can manually enter the node type, edge type,
node index attribute and edge source attribute names, as well as a Node ID Entry. Otherwise it is
possible to use the entire Graph or Graph Selection. It is moreover possible to select if the PPI of
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interest need to be conserved in different species and/or in different tissues. Once clicked Search
the retrieved interactions (and interactors) will automatically be added to the network.

3.3.3 UniProt
Select Database -> Uni Prot Annotations. Select a node type and UniProt ID attribute using the
respective drop down menus. You can click the "use selection only" to narrow the search. You
can select up to 3 available line parsers, and then select all of the databases/information platforms
desired. Finish by clicking "add".

3.3.3.1 Gene Ontology
Querying UniProt provides the possibility to annotate nodes with data included in all the ontologies
supported by UniProt (listed at http://www.uniprot.org/database/). Among these ontologies,
the most widely used in biology is Gene Ontology (GO http://www.geneontology.org/). If
selected, the plugin will add all the terms associated with each node. This will provide the base to
automatically color nodes based on GO categories, with NAViGaTOR preset filters.

3.4 Structuring Networks from Annotation
Categorical annotations as described above, can be used to add structure to a network in the form
of subsets. In the following we describe the process of creating subsets from categorical attributes.

– Select the "Subsets" panel in the bottom part of the application.
– Chose the "Pen"-drop-down menu and select "Create Subsets from

Attribute".
– Enter the required fields:

– Select Type
– Select Categorical Attribute
– Select type of Subset

– Click "Create".
The following figure shows the result subset panel in the bottom of the NAViGATOR framework.

The first panel on the left shows a list of all subsets created for this network including attached
attributes, such as ID, type or name. The middle panel shows the number of nodes, objects and the
sum, for all selected subset (left panel) and intersections of these. The center shows bar plots for
both nodes and edges in randomly assigned colours. The right panel shows the list of nodes that
are member of the selected subsets. Each node is coloured according to the corresponding subset or
subset intersection.

http://www.uniprot.org/database/
http://www.geneontology.org/
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3.5 Visual Annotation

Incorporating this annotation information in the network visualization, by modifying the appearance
of nodes and edges, can greatly increase the interpretability of the network. Note: To change the
appearance of a node, edge or subset, the object has to be selected in the graph panel, see Chapter4.
As describe previously, nodes and edges can be annotated by qualitative and quantitative parameters.
In the following we will show different possibilities to visualize these attributes in a network with
NAViGATOR.

3.5.1 Visualization of Qualitative Node Attributes.

Visual Description Instructions

Node Label: Annotating each
node with a label/name. This can
be for example an identifier, a
gene symbol, name or role of the
object represented by the node.

Navigator Appearance Panel;
Open/Enlarge Basic Label Ren-
derer and Node Label; Select the
"Source" to be displayed as label and
adjust other font parameter.

Coloured nodes: This type of vi-
sualization is often used to indi-
cate different categories, such as
the ones obtained from biologi-
cal process or molecular function
Gene Ontologies.

Navigator Appearance Panel;
Open/Enlarge Basic Node Ren-
derer, Color; Select the nodes of
one type. Click in the colored field
and select the preferred colour in the
color-selection pop-up.

Node highlighting: Nodes that
have special meaning or indica-
tions, such as drug targets or net-
work hubs can be emphasized by
highlights.

Navigator Appearance Panel;
Open/Enlarge Basic Node Ren-
derer, Highlight; Select the nodes of
one type. Click in the colored field
and select the preferred colour in the
color-selection pop-up.

Shaped categories: Similar to
color, different shapes can in-
dicate different groups or com-
munities. In gene-regulatory or
PPI networks, frequently a com-
bination of both is used, where
green and red, and up- and down-
pointing arrows indicate up- and
down-regulated genes, respec-
tively.

Navigator Appearance Panel;
Open/Enlarge Basic Node Ren-
derer, Shape; Select the nodes of one
type. Modify the shape by adjusting
the corresponding drop-down field.
Options are: Ellipse, Rectangle, Trian-
gle (up), Triangle (down), Diamond,
and Polygon. The height and width
parameters specify the dimensions of
the shape.
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3.5.2 Visualization of Quantitative Node Attributes.

Visual Description Instruction

Node size: Similar to the pre-
vious, it can used to represent
the importance of vertices with
respect to a continuous feature.
Both transparency and size can
significantly increase the inter-
pretability of a network by fad-
ing out or reducing unimportant
information.

Navigator Appearance Panel; Open/Enlarge
Basic Node Renderer and Filters; Use the Plus
button to choose and add the Node Matrix
Filter. Define a name and click OK. The new
filter appears in the Filter section. The table of
different numeric attributes (columns) and vi-
sual parameters (rows) is shown. By selecting
the radial buttons for Width and/or Height,
the size of the nodes will be set relatively to
the corresponding node attribute.

Node transparency: This tech-
nique can be used for instance
to put emphasis on nodes that
show a high range in a quantita-
tive measure, such as expression,
statistical significance, centrality,
etc.

Navigator Appearance Panel; Open/Enlarge
Basic Node Renderer and Filters; Use the Plus
button to choose and add the Node Matrix
Filter. Define a name and click OK. The new
filter appears in the Filter section. The table
of different numeric attributes (columns) and
visual parameters (rows) is shown. By select-
ing the radial buttons for Transparency, the
transparency of the nodes will be set relatively
to the corresponding node attribute.

Node highlight: This technique
can be used for instance to in-
dicate the importance of nodes.
The highlight can increase in size,
for instance, with respect to quan-
titative measures such as gene ex-
pression, statistical significance,
centrality, etc.

Navigator Appearance Panel; Open/Enlarge
Basic Node Renderer and Filters; Use the Plus
button to choose and add the Node Matrix
Filter. Define a name and click OK. The new
filter appears in the Filter section. The table
of different numeric attributes (columns) and
visual parameters (rows) is shown. By select-
ing the radial buttons for Highlight size, the
size of the highlight will be set relatively to
the corresponding node attribute.

Spokes visualization: Similar to
color or shade, the spoke visual-
ization can indicate numeric at-
tributes. Each attribute is shown
as a stacked level or bar plot at-
tached to the outer side of each
node. The advantage to this vi-
sualization is that multiple at-
tributes can be shown at the same
time. See Chapter 4 and 6 for
more examples.

Use the Plus Button in the top right to add the
Spoke Renderer to the Navigator Appearance
Panel. Different parameter define the type of
spoke, orientation, and maximal length. To
add attributes, use the Plus button under Avail-
able Attributes. The attributes are added to
the table and can be activated by the Show
checkbox. To adjust the color you can use the
corresponding color field and pop-up.
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3.5.3 Visualization of Qualitative Edge Attributes.

Visual Description Instruction

Edge Label: Annotating each
edge with a label/name. This
can be for example an identifier,
name, or the type of connection
or interaction, represented by the
edge.

Navigator Appearance Panel;
Open/Enlarge Basic Label Ren-
derer and Edge Label; Select the
"Source" to be displayed as label and
adjust other font parameter.

Edge colors: Different colors can
indicate different categories of
network relations, for instance,
in PPI networks, the difference
between protein complexes and
regular interaction, levels of pos-
itive/negative co-expression, or
PPI deregulation in normal vs
cancer tissues.

Select the edges of one type. Go to Nav-
igator Appearance Panel; Open/Enlarge
Basic Edge Renderer, and open the
Color section. Click in the colored field
and select the preferred colour in the
color-selection pop-up.

Edge type: Similar to color, the
type (stipple) of an edge can in-
dicate different types of relations.
This can be beneficial to visual-
ize, for instance, train lines that
are only in service for specific
times of the day.

Select the edges of one type. Go to Nav-
igator Appearance Panel; Open/Enlarge
Basic Edge Renderer, and open the
Style section. Use the parameters to
adjust the appearance of the edges. E.g.
Use the stipple checkbox to plot a
dashed line for each edge.

Edge arrow type: Similar to the
edge type, the symbol at the be-
ginning or end of an edge can in-
dicate different types of relations.

Select the edges you want to activate the
arrows. Go to Navigator Appearance
Panel; Open/Enlarge Basic Edge Ren-
derer, Head & Tail; Modify the shape by
adjusting the corresponding drop-down
fields for Head or Tail. Options are: Ar-
row, Circle, None. The height and width
parameters specify the dimensions of
the shape.

Edge directionality: The arrows
indicate the direction of the con-
nection. For instance, trains or
goods going from one city to an-
other.

Navigator Appearance Panel;
Open/Enlarge Basic Edge Ren-
derer, Arrows; Select the edges you
want to activate the arrows. Modify the
shape by adjusting the corresponding
drop-down fields for Head or Tail.
Options are: Arrow, Circle, None. The
height and width parameters specify
the dimensions of the shape.
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3.5.4 Visualization of Quantitative Edge Attributes.
Visual Description Instructions

Edge thickness: Similar to color
and shade, the thickness of
an edge can indicate different
strength or type of relations. This
can be beneficial to visualize, for
instance, gene co-expression in a
PPI or gene-regulatory network.

Navigator Appearance Panel;
Open/Enlarge Basic Edge Ren-
derer and Filters; Use the Plus button
to choose and add the Edge Matrix
Filter. Define a name and click OK.
The new filter appears in the Filter
section. The table of different numeric
attributes (columns) and visual parame-
ters (rows) is shown. By selecting the
radial buttons for Width, the width of
the edges will be set relatively to the
corresponding edge attribute.

Edge transparency: Trans-
parency can be used to indicate
the strength of an interaction.
In gene-regulatory networks
it can be utilized to visualize
the probability that a regulatory
factor controls a certain gene.

Navigator Appearance Panel;
Open/Enlarge Basic Edge Ren-
derer and Filters; Use the Plus button
to choose and add the Edge Matrix
Filter. Define a name and click OK.
The new filter appears in the Filter
section. The table of different numeric
attributes (columns) and visual parame-
ters (rows) is shown. By selecting the
radial buttons for Transparency, the
transparency of the edges will be set
relatively to the corresponding edge
attribute.





4. Visualization

4.1 Visualization Types
NAViGATOR supports different visualization types, so called Graph Views. They are special tabs in
the center of the workspace that allow the user to interact with the graph structure, network attributes,
and data in different ways. A graph view is bound to the graph for which it is created. When a graph
is closed, graph views that are bound to it will no longer be available. When a graph is created, some
views will be generated by default, while others can be added to the graph afterwards. The most
commonly used views are:

– Graph Layout
– Spreadsheet
– Matrix View
– Bar Chart
There are two ways to create new graph views for an existing graph:

1. From within an existing graph view tab, right click
on the tab title. A drop-down menu will appear
with a list of all the possible views that can be
generated for that graph.

2. From the Workspace tab, expand your net-
work, then Graph Data. Right click on
OGLGraphView and select Graph View. From
the menu it is possible to add a new view or show
the selected graph.
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4.1.1 Graph Layout ("OpenGL")

After creating a new network, it will be first visualized in the "Graph View" panel. The default graph
layout displayed is the GRIP layout. NAViGaTOR offers a variety of different layouts, see Section
8.3.6 "Network Layouts" for more details.

4.1.1.1 Graph Layout Menu Bar

In the following we will describe a few basic functions in the NAViGaTOR graph view:

A Selection Tool: Use this tool to select single elements or objects. A mouse click on the targeted
element selects it. The "Ctrl"-Key enables the selection of several elements.

B Lasso Tool: Use this tool to select a group of elements or objects. Draw a circle around the
targeted elements.

C Move: Use this tool to move a selection of elements or the entire network.
D Scaling: Use this tool to scale a selection of elements or the entire network.
E Rotation: Use this tool to rotate a selection of elements or the entire network.
F Navigate: Use this tool to navigate through large networks.
G Curved Edges Use this tool to curve the edges of your graph.
H Curved Planar Use this tool to arrange the nodes in a planar graph in a radial way.
I Planar Layout Use this tool to create a planar layout of the selected nodes.
J Circular Use this tool to create a circular layout of the selected nodes.
K Node Swap Use this tool to randomly or guided swap node locations.
L Original Size Use this tool to reset the network to it’s original size.
M Center Use this tool to move the network to the center of the Graph View panel.
N Zoom In Use this tool to zoom in.
O Zoom Out Use this tool to zoom out.
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4.1.2 Spreadsheet
The spreadsheet view contains three different tabs, showing the information for all nodes, edges
and subsets, respectively. This comprises network attributes that are imported when loading the
network, or while annotating edges and nodes with additional information. Additionally, it contains
all dynamically generated properties, such as node degree, gene ontology function or the results of
network analysis algorithms like community search.

4.1.3 Edge Matrix Layout
Edge-matrix or heatmap visualizations of networks, can be utilized to depict the edges and edge
weights between the vertices in a network. Directed networks result in a non-symmetric matrix. This
visualization can highlight densely connected subnetworks, by clustering the nodes according to a
topological or content specific similarity.

Instruction Open the Matrix View panel
in the central area of NAViGaTOR. The
matrix view shows a dot for each edge. Ad-
ditionally, labels can be added to the vi-
sualization. The matrix can be sorted via
different attributes or algorithms, see ??
Sorting. Finally, several bar chart can be
attached to each of the left or the top axis.
Add Label Use the right-click menu on

one of the axis (left/top) and select
"Labels"-"by Attribute" and the cor-
responding label.

Sort Axis Use the right-click menu on one
of the axis (left/top) and select "Or-
der" and the corresponding sorting.

Add Bar Chart Use the right-click menu
on one of the axis (left/top) and use
"Charts" to add a selection of at-
tributes as bar charts to the axis.
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4.1.4 Bar Chart

This graph view displays graph attributes in a bar chart format. There are three tabs in this view,
one each for Nodes, Edges, and Subsets,
which can be selected in the lower left of
the view. To add an attribute to the Bar
Chart Graph view, right click anywhere on
the tab, and select from the available at-
tributes in the Charts sub-menu. To change
the ordering of the objects in the bar chart,
right click anywhere on the tab, and select
from the available sorting methods in the
Order sub-menu. To add a label for each
object, right click anywhere on the tab, and
select from the available attributes in the
Labels sub-menu. The amount of space re-
served for the label can be altered by click-
ing and dragging the border between the
labels and the bar chart itself.

4.2 Network Layouts

4.2.1 Static Layouts

Static Layouts attempt to optimize all or a part of the graphs layout automatically. You can reach
these layouts either using the "Layout" menu in the top-menu or using the "Graph View" menu bar.

4.2.1.1 Planar Layout

The planar layout is simple and easy to visualize for small and sparse networks. The main advantage
is that individual nodes can be arranged with respect to any ordered node attribute, such as, node
name, or biological features such as gene ontology and biological function. The edges are drawn as
convex curves in one of the two half-planes separated by the line.

Instruction Select all nodes to be aranged by the planar layout. Use the "Graph View" menu and
select the button for planar layouts I.
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4.2.1.2 Circular Layout
The nodes in the circular layout are placed equidistant from the graph, aiming to minimize overlap-
ping nodes, see Figure ?? E. Despite its simplicity, the technique is widely used to visualize biological
networks such as protein complexes, drug-protein, miRNA-gene and phylogenetic networks.

Instruction Select all nodes to be aranged by the planar layout. Use the "Graph View" menu and
select the button for circular layouts J.

The radial layout or balloon layout are special tree-based visualizations incorporating the idea of
circular layouts. The radial approach places the nodes onto concentric circles relative to their depth
in the tree. The balloon view of a tree projects all sibling subtrees onto circles attached to the father
node.
Radial Layout
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Instruction Move the root node in the center. Select all child nodes of root apply the circular layout.
Move the root in the center of the circle. Repeat this approach iteratively.

4.2.1.3 Hive Plot (Spoke)
Similar to other approaches, the objective of a hive plot is to create rational, informative and
reproducible layouts. The nodes are placed on multiple radially arranged straight lines originating in
the center, representing linear axes with respect to a well-defined coordinate system. This creates a
compact and reproducible layout with perceptual uniformity, where connections are easy to follow.

Instruction Create a subset for each group of nodes to be visualized as one of the axes. You can
reach the hive plot layout using the "Layout" menu in the top-menu. It will request you to select
the subsets to be used. When clicking the "OK" button, each group will be arranged as straight line
originating in the center. The usage of the Curved Edges tool (G) can improve the visualization.

4.2.1.4 GRIP
Graph dRawing with Intelligent Placement - GRIP - has been designed to effectively visualize
very large graphs. It applies a multi-dimensional force-directed method in combination with a fast
energy function minimization. Intelligent vertices placement ensures that the running time and space
complexity of a network are near linear in the number of vertices.
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Instruction Select the nodes to be arranged using the GRIP layout. When not selecting any node
the entire network is used. You can reach the GRIP layout using the "Layout"-"Static Layout" menu
in the top-menu.

4.2.2 Dynamic Layouts

Dynamic Layouts attempt to constantly optimize the layout of the graph, unlike a Static Layout,
which will only execute the layout algorithm once. For example, the included Force Directed layout
will attempt to bring interacting nodes a specified distance apart. If the user moves one of these
nodes in a graph view, the dynamic layout will adapt to the change and push or pull the node back
towards an ideal distance.By default, there are no Dynamic Layouts added to a graph.
Add To add a layout, click on the ’+’ button in the upper right of the tab. You will be given a list of

possible layouts to choose from.
Remove To remove a Dynamic Layout, click on the menu arrow on the right side of the correspond-

ing layout header, and select ’Delete Dynamic Layout’.
Start/Stop Dynamic Layouts can be stopped and started by toggling the Play arrow button in the

upper right of the tab.
Lock Nodes From this tab, nodes can also be set to a ’locked’ state. In this state, they will not

respond to any attempts to be moved by a Dynamic Layout. To set nodes to locked or unlocked,
select a set of nodes in a graph view, and click on the corresponding padlock icon at the top
right of the Dynamic Layout tab.

Multiple dynamic layouts can be added to a single graph to produce complex layout strategies. How
they interact depends entirely on the layouts used, and some results may be unpredictable. If a
combination of Dynamic Layouts turns out to be problematic, simply stop the layout process and
perform a static layout.

4.2.2.1 Attractor

The Attractor Dynamic Layout constrains nodes within the same subset to the same area in the
layout. Nodes in active subsets will be constrained to a single area surrounding the subset’s parent
node. The desired width and height of the area to be occupied by the subset can be set by the width
and height controls. Deactivated nodes will not be affected by the layout.
Instruction Open the Layout panel in the bottom area of NAViGaTOR. Use the "PLUS" button to
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add the attractor layout.

It shows a list of all subsets available for this network. Select all subsets to be arranged in separated
areas and click "Activate Selection" or manually select each subset and use the "Active" check-box in
the controls. The Width and Hight parameter can be used to refine the outcome. The following figure
shows two networks, (1) network with detected communities in GRIP layout and (2) visualization of
the network using the attractor layout.

4.2.2.2 Force Directed

The Force Directed layout attempts to move connected nodes to a set distance from each other, by
applying a virtual force to each node from every edge connected to it. From Force Directed control
panel, the distance between connected nodes can be set, as well as the level of force which will be
applied to each node for every iteration of the algorithm.
Instruction Open the Layout panel in the bottom area of NAViGaTOR. Use the "PLUS" button to
add the force directed layout.

4.2.2.3 GRID Variant

The GRID Variant is an optimization of the Force Directed Layout that divides the graph into a grid,
and only performs layout tasks for nodes that exist in the same or adjoining grid sections. This layout
has identical controls and analogous behaviour to the Force Directed layout.
Instruction Open the Layout panel in the bottom area of NAViGaTOR. Use the "PLUS" button to
add the GRID variant layout.
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4.2.2.4 Projector
The Projector layout translates node attributes into X or Y coordinates.
Instruction Open the Layout panel in the bottom area of NAViGaTOR. Use the "PLUS" button to
add the Projector layout.

4.3 Appearance of Network Components

The appearance of each component in the network, namely nodes, edges, node labels and edge
labels, can be adjusted. The appearance panel provides different "Renderer" change attributes such
as color or shape. Note: To manipulate the following features, ensure you select the objects in the
network you wish to work on. In the following we will describe how to change the appearance of
different components. Note: To manipulate the following features, ensure you select the objects in
the network you wish to work on.

4.3.1 Basic Node Appearance
The "Basic Node Renderer" enables to change various attributes of selected nodes:

4.3.1.1 Color
Color Clicking on the color button will open a color

selection dialog with which to select a nodes color.
Opacity The node’s transparency can be changed by

using the slider dropdown beside the opacity value,
or by manually entering a value between 1 and
100.

4.3.1.2 Shape
Shape Clicking on the node shape drop-down list will

select between the available shapes for the node
renderer.

Height & Width Node height and width can be manip-
ulated using their respective controls, and may be
locked to having the same height and width by
clicking on the chain link icon.

Rotation Rotation can be altered by dragging your cur-
sor around the rotation circle or using the numer-
ical control.

Snap Edges to Midpoint You can "snap edges to mid-
point" by selecting this box.

4.3.1.3 Highlight
Highlighting a node by clicking on the enable checkbox will draw a shape around the primary node
shape.
Shape The highlight’s shape can be altered through the shape dropdown list.
Size The size control will set the distance from the primary shape that the highlight will extend.
Color The color box will open a dialog to select the highlight color.
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4.3.1.4 Filters
Click the filters drop down menu and select the "+" sign to add 1 of 6 default filters. You can choose
from:

– Time Node Filter
– Rome Node Filter
– OBO Color Filter
– Node Matrix Filter
– Comparison Node Filter
– Color Scheme Filter

Click "add". You can change the name in the Graph Data Name box that appears. Select "OK". To
change the features, click the drop down arrow to the left of the filter name. Each filter has different
changeable features. Clicking on the arrow to the far right gives you the option to apply it to all
objects, apply it to a subset, or to delete the filter.

4.3.2 Edge Appearance
The "Basic Edge Renderer" enables to change various attributes of selected nodes:

4.3.2.1 Color
Color Clicking on the color button will open a color

selection dialog with which to select an edge’s
color.

Opacity The edge’s transparency can be changed by
using the slider dropdown beside the opacity value,
or by manually entering a value between 1 and
100.

4.3.2.2 Style
Width To change the width, press the up or down arrow

to select a number between 1 and 10.
Curve To change the curve, click the drop down menu

and select "smooth curve" or "sharp curve" or
none.

Automate You can automate and reset the edge curve
by clicking the "automate" and "reset" buttons.

Stripple To give the edge a stipple (mark it with dashed
specks), click to check off the stipple box.

4.3.2.3 Head & Tail
By clicking on the arrows drop down menu, you can
change the shape, length, and width of the source and target arrows. Click the target and source drop
down menus to select a shape, and click the up or down arrows to increase or decrease the length
and width simultaneously.

4.3.2.4 Filters
Click the filters drop down menu and select the "+" sign to add 1 of 5 default filters. You can choose
from:
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– Time Edge Filter
– Rome Edge Filter
– Origin Edge Filter
– Edge Matrix Filter
– Comparison Edge Filter

Click "add". You can change the name by typing in the Graph Data Name box that appears. Select
"OK". To change the features for each filter, click the drop down arrow to the left of the filter name.
Each has different changeable features. Clicking on the arrow to the far right gives you the option to
apply it to all objects, apply it to a subset, or to delete the filter.

4.3.3 Label Appearance

To change node and edge labels, the "Basic Label Renderer" is required. Here you can change for in-
stance:

4.3.3.1 Node Label
Source Set the Variable shown as label.
Length Limit Select the Label size limit.
Foreground Color Change color of the node or edge la-

bel.
Opacity Change the opacity of the node or edge label.
Background Color Change color of the background of

the node or edge label.
Opacity Change the opacity of the background of the node

or edge label.
Auto Color Automatically sets color
Size Size of the label
Horizontal Justify Horizontal orientation of the label
Vertical Justify Vertical orientation of the label
Distance Distance from starting point of the label
Angled Activate rotation feature
Anchor Point Rotate label according to chosen angle
Flip Flip rotated label by 180 degree
Auto Angle Set angle automatically

4.3.3.2 Edge Label
Source Set the Variable shown as label.
Length Limit Select the Label size limit.
Foreground Color Change color of the node or edge la-

bel.
Opacity Change the opacity of the node or edge label.
Background Color Change color of the background of

the node or edge label.
Opacity Change the opacity of the background of the node

or edge label.
Size Size of the label
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Horizontal Justify Horizontal orientation of the label
Vertical Justify Vertical orientation of the label
Distance Distance from starting point of the label

4.3.4 Spoke Visualization
Similar to color or shade, the spoke visualization can indicate numeric attributes. Each attribute is
shown as a stacked level or bar plot attached to the outer side of each node. The advantage to this
visualization is that multiple attributes can be shown at the same time. See Chapter 3 and 6 for more
examples.

Use the Plus Button in the top right to add the Spoke Renderer to the Navigator Appearance Panel.
Different parameter define the type of spoke, orientation, and maximal length. To add attributes,
use the Plus button under Available Attributes. The attributes are added to the table and can be
activated by the Show checkbox. To adjust the color you can use the corresponding color field and
pop-up.



5. Network Analysis

The analysis menu includes several graph analysis methods that will be listed in Sections 5.1, 5.3,
5.4, 5.5 The Analysis Tab combines multiple methods of graph analysis into one interface and will
be listed in Section 5.2, 5.6.

5.1 Add Dynamic Parameter
Dynamic parameters appear in the graph workspace as regular attributes, however, their values are
determined by features of the graph, such as topology, and are not editable. Creating a dynamic
parameter can be very useful for translating graph topology or complex combinations of graph
attributes into visual properties in a rendering, or for sorting and selecting subsets of a graph that
meet analysis criteria. Any dynamic parameter can be removed right clicking on it in the workspace
area, under graph data, and selecting Data -> Delete selected.

5.1.1 Node Degree
The degree of a Node is defined as the number of edges touching that node. This function calculates
degree (i.e. number of interactors) for each node. The output is a node attribute. Once selected node
degree, it is possible to name the attribute or use the default "degree" name. Once clicked create
the degree is added and it changes in real time every time there is a change in the network.

5.1.2 Subset Size
Subset Size calculates the number of nodes and edges present in a subset. The output is a numerical
parameter added to each subset.

5.1.3 Subset Attribute Statistics

String attribute
Any node attribute in the string format can be used to calculate the average (Average string length),
maximum (Maximum string length) and minimum (Minimum string length) length of such string
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across all components of the subset. The output is a subset attribute.

Numeric attribute
Any numeric attribute can be used to calculate the Maximum, Minimum, Mean, Median, Mode
and variance of such attribute in the subset. The output is a subset attribute. Mode count also
provides the number of times the value identified in Mode is present in the subset. Null count
identifies the number of empty cells for the attribute being tested in the subset.

Subset elements
Total returns the number of nodes that are present in the subset, while Distinct returns the number of
nodes unique to the subset (based on a specified attribute). The output is a subset numerical attribute.

5.1.4 BFS Count
Centrality indices are widely used analytic measures for the importance of nodes in a network.
Closeness centrality is very popular among these measures, and it sums the distances of a node to all
other nodes. The currently best algorithms are based on breadth-first search (BFS) from every node.
This function provides five options:

– BFS count directed, counts the number of directional BFS that pass through an object.
– BFS count undirected - counts the number of undirectional BFS that pass through an object.
– Closeness centrality incoming - provides ranking for each node based on the average length of

incoming BFS paths.
– Closeness centrality outgoing - provides ranking for each node based on the average length of

outgoing BFS paths.
– Closeness centrality undirected - provides ranking for each node based on the average length

of any BFS path.
The output is an attribute.

5.1.5 All Pairs of Shortest Paths (APSP) Count
A path is a sequence of consecutive edges in a graph connecting a set of vertices. The length of a
path is defined by the number of edges in such sequence. The path with minimal length between two
vertices is a shortest path, and defines the distance between the two vertices. When clicking APSP
Count, it is possible to select undirected (where the shortest path count increases with every shortest
path passing through the object), directed source (where the shortest path count adds a value from
1.0 to 0.0 for each shortest path passing through the object, decreasing linearly as the path leaves the
source node) and directed target (where the shortest path count adds a value from 0.0 to 1.0 for each
shortest path passing through the object, increasing linearly as the path approached the target node).
The output is an attribute.

5.1.6 Unweighted APSP Count
This analysis produces APSP as in Section5.1.5, but uses an algorithm that counts approximate
number of APSP. When clicking it is possible to select: Any (traverse the graph using any edge),
Ingoing (traverse the graph using only incoming edges), Outgoing (traverse the graph using only
outgoing edges). It is also possible to select one (or multiple) subsets and obtain only the count
related to that subset. The output is an attribute.

5.1.7 Expression
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Expression allows to perform any mathematical calculation using numerical
attributes and dynamic parameters. Once selected expression, it is possible
to name the graph data and select the type of graph element to use so that
the attributes associated with it will automatically be shown with a letter
associated to them. It is then possible to write any mathematical expression
using these letters (i.e. a+1, a+b/2 ...). For more details see https://docs.
oracle.com/javase/8/docs/api/java/util/regex/Pattern.html

5.1.8 OBO Category

Selecting OBO category allows to automatically add GO data to the graph
using preset selections such as Molecular Function or Biological Process. The
node IDs to obtain results must be in the UniProt ID format.

5.2 Topology

The combo box in the upper right corner of this tab selects which analysis method to use. Selecting
a method will automatically begin analysis with default settings; the results will appear as a control
panel with interactive components and methods for refining the analysis and manipulating the results.
Clicking on the search button beside the combo box will run the analysis with the currently selected
view, replacing any previous findings.

5.2.1 Biconnected Components

A biconnected component (also known as a block or 2-connected component) is a maximal bicon-
nected subgraph).

After executing this analysis method, you will see a matrix.
The headers of the matrix represent individual biconnected components. The attribute used to

label the objects represented by the headers can be changed by using the combo box in the upper left
hand corner.

Matrix cells represent articulation points, or nodes that when removed would disconnect two
biconnected components from each other. Right clicking on a component or an articulation point
will give you options for copying that object to the current graph selection.

5.2.2 Shortest Path

The shortest path feature finder finds the least number of edges required to travel from one node to
another in the graph.

Executing a shortest path search will automatically find shortest paths between all the nodes
in the current selection. Be aware that on large graphs or selections, this may take some time to
complete.

Once the shortest paths are found, they are displayed as a matrix. Each cell in the matrix
represents a path, with the path length displayed as a number, and the corresponding column and row
represent the source and target respectively. Right clicking on a path will give you options to copy
that path to the current selection. The attribute used to label the objects represented by the headers
can be changed by using the combo box in the upper left hand corner.

https://docs.oracle.com/javase/8/docs/api/java/util/regex/Pattern.html
https://docs.oracle.com/javase/8/docs/api/java/util/regex/Pattern.html
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5.2.3 Inter-Subset Edges
This analysis allows you to find which edges provide connections between two subsets of nodes in
the graph.

In the control panel for this feature, the source and target tables allow the selection of a single
subset each. Any edges that provide connections between nodes in the selected subsets will be
displayed in the table to the right. These edges can be copied to the current selection by using the
transfer dropdown menu located in the top right corner of the control panel.

5.2.4 Inter-Subset Edge Count
Based on Section5.2.3, this analysis count the number of edges that connect two subsets. The output
is a matrix of subset ids in which each cell shows the number of edges connecting a subset (from
row) to another subset (from column).

5.2.5 Inter subset shortest path
Similarly to what described in Section 5.2.2, this function identifies shortest paths between two
subsets. When clicking on Inter subset shortest path, two panels will open (Source and Target
Child) that list all the subsets. Upon selecting one subset from each of the two lists, a matrix will
appear on the right including all shortest paths between one element of one subset and another
element of the other subset. Right clicking on the matrix gives the possibility to use data for selection
of graph elements or to export it to clipboard.

5.2.6 RMW finder
This function identifies upstream Regulators (red), downstream Workhorses (blue) and middle
Managers (green). Right clicking one of the colors allow to Add to selection or Replace selection
with the identified nodes.

5.3 Clustering
5.3.1 Clique search

Clique search tool searches for fully connected subgraphs (cliques) in the graph.
The options are:
– Exclude Objects - these objects will be removed from the search network
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– Limit To Node Types - search network will be restricted to the nodes that match listed types
– Limit to Edge Types - search network will be restricted to the edges that match listed types
– Minimal Size - the output will be restricted to subgraphs of minimal size and above.
– Output Prefix - the prefix for the subset node type name.
Output: New subsets

5.3.2 Communities search

Communities search tool searches for dense subgraphs in the graph.
The options are:
– Exclude Objects - these objects will be removed from the search network
– Limit To Node Types - search network will be restricted to the nodes that match listed types
– Limit to Edge Types - search network will be restricted to the edges that match listed types
– Minimal Size - the output will be restricted to subgraphs of minimal size and above.
– Output Type - subgraphs can be output as subgraph index in a new attribute (the default

option), or new subsets
– Output Prefix - the prefix for the new attribute name or the subset node type name.
Output: New attribute, or new subsets
The advanced comunity seach gives options to exclude a set of objects

5.3.3 Connected components search

Connected components search tool searches for connected subgraphs in the graph.
The options are:
– Connectivity Type - Weak (default option) or Strong
– Exclude Objects - these objects will be removed from the search network
– Limit To Node Types - search network will be restricted to the nodes that match listed types
– Limit to Edge Types - search network will be restricted to the edges that match listed types
– Minimal Size - the output will be restricted to subgraphs of minimal size and above.
– Output Type - subgraphs can be output as subgraph index in a new attribute (default option),

or new subsets
– Output Prefix - the prefix for the new attribute name or the subset node type name.
Output: New attribute, or new subsets

5.3.4 Context search

Context search tool searches for the nodes that are within specified distance from the starting node(s).
The options are:
– Node(s) - nodes from which the search starts.
– Maximal Depth - maximal depth of the search
– Exclude Objects - these objects will be removed from the search network
– Limit To Node Types - search network will be restricted to the nodes that match listed types
– Limit to Edge Types - search network will be restricted to the edges that match listed types
– Output Subsets - the result of the search will be output as a new subset
– Output Prefix - the prefix for the subset node type name.
Output: Active graph view selection and optionally new subset
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5.4 Enrichment Analysis

The plugin allows to calculate enrichment of one specific subset compared to another. In the dialog
window that pops up, Node Set 1 and 2 needs to be filled with OID of subsets of interest. The output
can be a virtual or a real edge between the two sets and the plugin can calculate overlap, Fisher’s
p-value and Monte Carlo (MC) p-value.

5.5 Flow Analysis

The plugin allows exploring the graph as a flow network. The analysis is based on the approach
used for electrical circuits as explained at https://www.allaboutcircuits.com/textbook/
direct-current/chpt-10/node-voltage-method/. The model uses linear relationship be-
tween edge resistance and the difference of potentials.

Flow analysis dialog. Flow analysis model is controlled through flow analysis dialog component.
The top part of it has a table where variable requests are entered. The creation of a new request is
started by pressing “Add” button to add new line in the table. The line is then changed to create a
desired variable request. Unneeded line can be deleted by pressing “Delete” button. Head (start)
and Tail (end) nodes should be specified using OID (it is possible to use a selected one right clicking
and selecting Paste from graph selection) The plugin can calculate and output simple and aggregate
variables.

Simple variables: Simple variables are node variables (potential) and edge variables. The
latter include flow (current in the above chapter on electrical circuits), absolute flow, potential
drop (difference between the potentials of tail and head nodes), absolute potential drop, resistance
(ratio between flow and potential drop) and conductivity (inverse of resistance). Resistance and
conductivity are output as new, virtual, edges.

Aggregate variables The collection of values can be aggregated, to produce a new value based on
the minimum, maximum, sum, sum of absolute, average, average of absolute of the collection
of values. Two types of aggregation are possible - simple aggregation and multi aggregation.

https://www.allaboutcircuits.com/textbook/direct-current/chpt-10/node-voltage-method/
https://www.allaboutcircuits.com/textbook/direct-current/chpt-10/node-voltage-method/
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Simple aggregation. For a node, the results of the adjacent edges are aggregated, producing a
node variable. For an edge, the results of the tail and head nodes are aggregated, producing an edge
variable.

Multi aggregation and solution scopes. While the calculation of simple variables and simple
aggregation is done over a single run for a pair of tail-head nodes, multi aggregation is performed
over a composite scope - multiple simulations over multiple tail-head node pairs. Aggregation scope
is generated based on the tail and head nodes. If head, or tail, or both nodes are subsets - containing
collections of nodes - the scope of the aggregation will be made of all possible tail-head combinations
between the two sets or between a single node and a set.

Source type and value. The source of the flow in the network can be either fixed flow from tail
to head, or fixed potential at the tail node, assuming that the head node has the potential of 0. The
value of the flow or potential difference is provided by the Value parameter.

Edge resistances. For the purpose of the simulation, all edges can be assumed to have equal
resistance of 1 or be assigned a value based on an existing numeric attribute. Solver type selector
decides which linear system solver is used. Available choices are direct solver which uses Cholesky
factorization and iterative solver. Direct solver has guaranteed accuracy and efficiencies in multi-
scope cases. Iterative solver has lower memory requirements. “Use Cache” checkbox - if the selected
solver will use a hard drive to permanently store results.

Save mode selector tell the solver which results are supposed to be permanently saved to the
hard drive - none, requested only or all, including the results for the variables that the requested
results may be based on. The solution is activated by pressing the “Solve!” button.

Outputs. The results of the simulation are output to the graph as global attributes and, in the
case of resistance and conductivity, virtual edges. The names of the attributes provide most of the
information that went into producing the attribute. It is worth noting though that any addition or
removal of graph objects or changing the value of the resistance attributes might make the computed
variable values inaccurate for some or all graph objects.

5.6 Ontology tab
The OBO Ontology tab is designed to browse Open Biomedical Ontology data. The table on the
left side of the tab shows the current selection of graph objects. If they contain OBO ontology
information, obtainable using the ’UniProt Annotations...’ database query, the relevant IDs will be
displayed in a list on the right side of the tab.





6. Tutorials

6.1 PPI Network Examples
6.1.1 Loading a PPI Network from IID

– Aquire protein interactions by querying the IID database: “http://iid.ophid.utoronto.ca/iid”
with a set of genes. Click “Download results” and save the results into a file.

– Import the tab-delimited file via the Navigator menu File-> Import, select a file and Click
“Next”. Set header size to 1 and click “Next”.

– Use the drop down fields to annotate the “Query UniProt” as source node and “Partner UniProt”
as target node. Click “Next”.
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– If required for further analysis, associate each of the other fields accordingly to source, target
or edge and add names to the columns manually or by clicking “Copy Title Line”. Click
“Next” to create the network.

6.2 World Network
6.2.1 MAP ATTRIBUTES TO NODE POSITIONS

The files included in this manual page were downloaded from http://openflights.org/. We are going
to use airports.csv, routes.csv,

Select File->Open from the main menu and select Delimited Text (.txt, .csv, .tab) as your file
type. Select the airports.csv file from the location you downloaded it to.

You will be presented with an Open Tab-Delimited File dialog. You should be comfortable using
this interface; if you need to learn how to use it, you can explore the instructions in Section2.2.3.

In the CSV Settings page, set the load type to Load new nodes. In the Set Header page, leave all
settings at their default. In the Set Node ID Columns page, set the fifth column as your Node Index.
In the Set Attribute Import page, set columns 7 and 8 as node attributes, with a Data Type of Double,
and Attribute Kind of Basic. Name them Lat and Long Respectively.

At this point, you can associate other attributes with nodes, such as long form Airport names
or countries. However, for the purposes of this example, we will only use the ones we just defined.
Click on the Open button.

Your graph should now be a single node, which is actually all nodes mapped to a single point.
To give these nodes a layout, select the Layout tab. From this tab, select the + button to add a new
Dynamic Layout. From the dialog that pops up, select the Projector layout and click Add. You will
be prompted to create a name, which you can leave as the default name ’Projector’. In the Layout tab,
you should now see the projector control panel. We will now map node attributes to X and Y coordi-
nates.
Map Node X Position to Long and Y Position to Lat.
You will now see what looks like an inverted map. We can convert
this to a familiar appearance by multiplying the Y Position by -1.

After changing the Y multiplier you should see a familiar map
of the world’s airports. We can make it cover a larger space by
increasing the sizes of the X and Y multipliers. A value of 8 and
-8 for X and Y respectively will make every node cover a degree of
Latitude/Longitude, which isn’t very precise, but when zoomed out,
gives a clearer visualization.

At this point, all our mapping is done. If you wish
to load air flight data into this graph, you can use the
routes.csv file. Load new nodes and edges from Tab-
delimited file. Specify a Header Size of 1. The Title
Row will update automatically. Select the Type column,
and set it to load as an Edge attribute, with the Attribute
Type String, and the Attribute Kind as Basic. The Opened
Graph

Once you have finished all these steps, you should see a graph in your Workspace, similar to
what you see below. From here you can explore the contents of the graph, using different Graph
Views, Searching, and Analysis.
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6.3 Spokes Visualization
6.3.1 Spoke Renderer

In this example, we will take a graph with existing Dynamic Attributes, add a Spoke Renderer, and
then apply a sorted circular layout.

To begin, download Spoke Renderer Example.n3e [[ToDo: link]]
Open this file in N3E. You should see a plain graph visualization. To add a

Spoke Renderer, in the top right of the Layers tab, click on the + button. This
will open the ’Add Layers’ dialog. From the available layers, select ’Spoke
Renderer’ and then click the ’Add’ button. When queried for a name, use the
default name provided.

You should now see the Spoke Renderer in the Layers tab. You may have
to scroll down to see it.

Nothing should have changed in the graph visualization. To quickly add
spokes to the graph, use the Selection tool, or the Select menu to select all
the nodes. When you have a selection of nodes, click the + button in the top
right corner of the Available Attributes panel. A dialog will ask you which
available attribute you would like to add. Select ’Degree’ from the combo box
and click the ’Add’ button.

Your graph should now have a spoke on every selected node, similar to this:

Notice that each spoke is oriented in the same direction. This direction can be changed for
selected nodes by using the Angle widget in the Spoke Renderer panel. The distance of the spoke
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from the surface of the node, the width of the spoke, and the length of the spoke can also be changed
manually. Feel free to play with these settings on your own to see how they affect the visualization.

In addition, you can turn the rendering of an attribute spoke on and off by selecting nodes and
toggling the ’Show’ checkbox in the Available Attributes table.

Now, add another Available Attribute to all the nodes using the same steps we used above, except
this time select the ’Closeness Centrality (Undirected)’ attribute.

Each node should now have two spokes, emerging from opposite sides of the node. This is the
SPOKE Style for the spoke renderer, and is the renderer’s default setting. As attributes are added,
they will be distributed at regularly spaced intervals around the node. With just two attributes, this
places them 180 degrees from each other. This is only useful if many attributes are to be compared in
’free’ layouts such as grip. However, we can enhance the usefulness of our two spokes by combining
a layout with one of the other two styles.

We then apply a Sorted Circular Layout. Select all the nodes in the graph using the Selection
tool or the Select menu. From the Toolbar at the top of the OpenGL Graph View, select the drop-
down menu to the right of the Circle Layout Tool. You will see a sorting menu. There are many
sorting options available. One of the neatest for our purposes is the Hamming Sort. This sort
will lay out the nodes by placing them closest to other nodes with which they share neighbors.

You should get a layout that looks something like the one below.
Notice that the angle for each spoke has been set by the layout

algorithm. Though this is a good start, we can take several steps to
make the graph more intelligible. First, we can set the Spoke Style to
SPACED. This will stack the spokes on top of the node at regularly
spaced intervals, and make them easier to compare. Secondly, we
can better organize the edges by shifting their curve control points
toward the center of the layout. To to this, select all the edges, and
then switch to the Control tool. From the Control tool menu, select
the ’Scale Selection’ mode. Hold down the CTRL key and left click
on any of the control points and gently adjust the curves of the selection until your graph looks
something like the one below.

Notice that the edges are no longer intersecting as much with
other edges and nodes. If you are not satisfied with the curvature,
you can reset it at any time by double clicking on any control point
in the selection. You can also edit the control points individually for
any edge. Finally, we can further differentiate the edges by adding
an origin edge filter. In the Basic Edge Renderer panel, expand
the Filters panel. Click on the + in the upper right of the Filters
panel. Select the ’Origin Edge Filter’ in the dialog that appears,
and click the ’Add’ button. Use the default name for the new Filter.
The resulting visualization will automatically color edges according
to their point of origin in the layout, and the graph should look

something like the one below. With the graph topology and the spokes arranged to our liking, we
may want to add labels to the nodes in the graph. To do so, first select all the nodes in the graph using
the Selection tool or the Select menu. In the Basic Label Renderer panel, expand the Node Label
panel. Select the Source as ’Index’. All the selected nodes should now have labels displayed on the
outside edge of the node surface. You may have to zoom in to see them, as they overlap with the
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spokes of the Spoke Renderer. This can be adjusted in the Spoke renderer by increasing the Distance
setting. A setting of 12 should work for our graph, but you can change this to suit your tastes.

You should now have some idea of how to adjust the sizes and lengths of the spokes, as well as
the label size to produce a legible graph. This can be subjective, and changes from graph to graph
depending on the graph content and the desired size of the final illustration.

This is one possible visualization that can be produced by careful adjustment of each rendering
layer:

6.4 Importing Interaction Networks from the Internet

HRG
ORM2

FGA

FGG
AHSG

ITIH3

APOH

SPP2

FGB
ALB

ORM1

Many different types of interaction networks can be extracted
from the internet (ex: social network). For example, the
String framework (Search Tool for the Retrieval of Interacting
Genes/Proteins) is a database and web resource of known and
predicted protein-protein interactions.
The following instructions describe how to retrieve and visu-
alize data from String:

– Go to string-db.org
– Click on "exports" and download the network as simple tabular text output
– Save the file, open downloads and rename the file as a tab file (filename.tab)
– Create an empty graph on Navigator by clicking File -> Empty Graph. Select File -> Import

and select the network from your downloads file
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– In the CSV Settings, select "load new nodes and edges"
– Some tab-delimited files have header lines reserved for describing the information contained

within. Indicate how many lines are being used for this purpose.You may also indicate a ’title
row’, a tab-delimited line that contains the names of the columns you wish to import. Select 1
for header size.

– Set Node ID Columns. For every imported tab-delimited file, two columns must be specified,
whose contents indicate the unique ID’s of the nodes to join with the edges in the graph. Use
the column header to select "source index" for column 1 and "target index" for column 2.

– Data can be imported by indicating the Attribute Type (text, double number, etc.), Attribute
Object (Node A, B, Edge), and a unique Attribute Name by which to reference the imported
Attribute. Select "source" for column 1 and "target" for column 2. For the desired column (ex:
coexpression) select "double". When the title row boxes become red, rename the according
columns.

– Select "done" and click the "new graph" tab to view your table.



7. Troubleshooting

If you are experiencing program errors in NAViGaTOR 3, check the Common Problems page to see
if a solution already exists.

If this does not solve your problem, please start a topic regarding the problem in the NAViGaTOR
3 User Group. Describe the nature of your problem, and describe the steps required to recreate it in
detail. We may ask you to attach copies of these two files:

error.log
output.log
These can be located in the directory in which NAViGaTOR 3 was installed.
We will not respond to problem reports that are vague or unhelpful, such as: ‘layout doesn’t

work.’

7.1 Common Problems

1. Navigator Won’t Start.
If you start the Navigator application and a window doesn’t appear you may have a corrupt
installation, or an unexpected configuration on your machine.

– Cause: You haven’t installed the correct version of Navigator
Solution: Verify that you have downloaded the correct installer for your operating
system and system architecture.

– Cause: You have an incompatible version of Java
Solution: Ensure that you have a Java Runtime of 1.7 or higher.

– Cause: You are missing the Visual C++ Redistributable for Visual Studio 2012
Solution: You are missing the Visual C++ Redistributable for Visual Studio 2012. You
can download a current version here.
If you’ve checked all these possibilities, please report this as a bug.

2. I’ve opened a graph, but don’t see anything in the Workspace.
Ensure that the graph is loaded correctly. You can check this from the ‘Workspace’ tab.
By default, every graph created in Navigator should have an OpenGL view. You should be able
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to see this view in the ‘Workspace’ tab under the subtree ‘Workspace->Your Graph->Graph
Data’. If there is not a listing for ‘OGLGraphView’ under this subtree, you can create it
by selecting your graph in the tree, then right-clicking and selecting ‘Graph View->New...-
>OpenGL View’.
If you have an OpenGL view, but it is displayed as a blank screen, there may be several causes.
Check in the Layers tab to see if there are any layers in the graph. If there are none, you will
have to select one or more layers to use in rendering the graph.

3. Navigator won’t open a file.
– Cause: You’re using the wrong file loader.

Solution: Some file types, such as PSI-MI or BioPAX, have similar file extensions, and
often cause confusion. Verify the type of file and ensure you are using the correct file
loader.

– Cause: The file is an XML file that doesn’t correctly follow an established schema.
Solution: XML files are sometimes generated to different standards of conformity with
suggested schemas. This problem must be dealt with on a file-by-file basis.
If you’ve checked all these possibilities, please report this as a bug.

4. There are analyses missing from the Analysis panel
– Cause: Your analysis panel is out of sink.

Solution: close the analysis panel and add it again using the plus sign above the panels.
If you’ve tried and it doesn’t work, please report this as a bug.



8. Dictionary

8.1 Menu

The application menu allows quick access to some common functions of Navigator 3.
Further details in Chapter 1.

8.1.1 File

8.1.1.1 Preferences

The preferences dialog, available through selecting File->Preferences in the main application menu,
allows the customization of some features of the Navigator application.

Types of editable preferences will be available in a list on the left side of this dialog. Selecting
from this list will open relevant controls on the right side of the dialog.

8.1.2 Edit

The edit tab in the main menu allows for the use of commands such as copying, pasting, merging,
and deleting nodes and egdes.

8.1.3 Selection

The selection tab in the main menu allow you to perform functions such as selection and deselection
of different types of nodes and edges, as well as copying and pasting of selected material.

8.1.4 Analysis

The Analysis Tab combines multiple methods of graph analysis into one interface. It allows you to
perform various functions including adding dynamic attributes, selecting Cliques, COPASI, context,
communities and connected components. It also allows for the merging of shared nodes, enrichment
analysis, flow analysis and Petri Net. Further details in Chapter 5.
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8.1.4.1 Subset
Subsets are subgraphs with common properties that are selected by the user according to the analysis
interest. Further details in Chapter 1, 4 and 5.

8.1.4.2 BFS
Bredth First Search counts the number of BDF passing through an object (directed or indirected).
Further details in Chapter 5

8.1.4.3 APSP
Counts number of all pairs of shortest paths passing though an object (directed or indirected).

8.1.4.4 Expression
Can be used to perform math calculations using any numerical attribute.

8.1.4.5 Cliques
This feature creates subsets with cliques identified using specific types of nodes or edge and size.
Subsets created are with cliques of at least size n.

8.1.4.6 Context
This feature retrieves nodes at a specific distance from selected nodes and can be filtered by node or
edge type. Retrieved nodes are at distance X from selected nodes.

8.1.4.7 Communities
This identifies dense subgraphs.

8.1.4.8 Connected Components
This identifies connected subgraphs in the graph.

8.1.5 Database
The Database tab allows you to search various databases including I2D, PathDIP and UniProt for
protein sequences and functional information.

8.1.5.1 BioModels
BioModels plugin provides access to BioModels database.

8.1.5.2 KEGG
KEGG plugin provides access to KEGG pathway database. Creates new network based on one or
more pathways.

8.1.5.3 IID Interactions
IID is an integrated protein-protein interaction database that can be queried through NAViGaTOR.

8.1.5.4 PathDIP Enrichment
PathDIP is an integrated pathway database that can provide pathway enrichment of the proteins
present in the network.

8.1.5.5 UniProt Annotations
Through this plugin it is possible to query the entire set of ontologies and annotations included in
UniProt (a reference database for proteins annotation).
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8.1.6 Graph

The Navigator workspace supports the editing of many graphs. Each graph will have it’s own
collection of graph objects, types, and attributes.

You can create new graphs, or open existing graphs. To create a new graph, select the File->
New -> Empty Graph menu item in the main menu. This will create an empty graph, with no graph
objects or attributes.

To load an existing graph, select the File -> Open menu item from the main menu. This will open
a dialog which will allow you to select different types of supported files to import into Navigator.
You can find out which types of files are supported, plus information on their uses and features in the
Importing Data section.

8.1.6.1 Graph Objects

Graph objects consist of nodes and edges.

8.1.7 Layout

The layout tab allows you to manipulate the visual presentation of your graph. You can easily center
the graph, as well as select from four types of static layouts.

8.1.8 Help

The help tab provides two types of help (online help and "about N3E) to facilitate the user’s use of
the program.

8.2 Panels

The Navigator 3 Workspace is divided into customizable panels containing multiple tabs. Each tab
is dedicated to a particular set of tasks in the Workspace (describing Graph Objects, searching for
Graph Features, manipulating Graph Subsets, etc.).

You can customize panels by clicking on the ’+’ symbol next to the last tab header, or by clicking
on an empty panel where prompted. This will open a popup menu with options for adding tabs or
splitting and merging existing tabs. To add a tab, follow the ’Add Tab’ menu item and select the type
of tab you’d like to add.

To split the current panel into two new panels, follow the ’Split Tabs’ menu item and select
whether you’d like to split the panel horizontally or vertically. To merge the tabs from the neighbour-
ing panel into the current panel, select the ’Merge Tabs’ menu item.

To remove an existing tab from a panel, click the ’X’ icon on that tab’s header.
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8.2.1 Appearance

8.2.1.1 Basic Node Renderer

The Node Renderer is used to define the appearance of a node on the graph canvas.
Node Label:

Color
Color Variable shown as label

Opacity Opacity of the edge
Shape
Shape Shape of the node

Ellipse, Rectangle, Triangle (Up),
Triangle (Down), Diamond and Polygon.

Height Height of the node
Width Width of the node

Rotation Rotation of the node
Snap Edges to Midpoint.

Highlight
Enable Enable the highlighting
Shape Shape of the highlighting

Size Thickness of the highlighting
Color Color of the highlighting

Filters Add filters
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8.2.1.2 Basic Edge Renderer
The Edge Renderer can define the appearance of an edge. Edge Renderer:

Color
Color Variable shown as label

Opacity Opacity of the edge
Style

Width Width of the edge
Curve Select the type of curvature of the edge.

Options are "None", "Smooth Curve",
and "Sharp Curve".

Automate Set the curvature automatically.
Reset Reset the settings.

Stipple Plot the edge as a dashed line.
Head & Tail

Head Selection of the sign attached
to the target of the arrow.

Width Width of the target sign
Length Length of the target sign

Tail Selection of the sign attached
to the source of the arrow.

Width Width of the target sign
Length Length of the target sign
Filters
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8.2.1.3 Basic Label Renderer

Node Label:
Source Variable shown as label

Length Limit Label size limit
Foreground Color Color of the label

Opacity Opacity of label
Background Color Color of Background

Opacity Opacity of Backtround
Auto Color Automatically sets color

Size Size of the label
Horizontal Justify Horizontal orientation of the label

Vertical Justify Vertical orientation of the label
Distance Distance from starting point of the label

Angled Activate rotation feature
Anchor Point Rotate label according to chosen angle

Flip Flip rotated label by 180 degree
Auto Angle Set angle automatically

Edge Label:
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Source Variable shown as label
Length Limit Label size limit

Foreground Color Color of the label
Opacity Opacity of label

Background Color Color of Background
Opacity Opacity of Backtround

Size Size of the label
Horizontal Justify Horizontal orientation of the label

Vertical Justify Vertical orientation of the label
Distance Distance from starting point of the label

8.2.1.4 Spoke Renderer
Spoke renderer lets the user map a quantitative attribute to bars for each node, that have a length
proportional to the attribute.

To use it, open the Appearance Panel. Use the PLUS Button to add a Spoke Renderer. To chose
a variable to be visualized as a spoke, use the PLUS button under Available Attributes. Select the
nodes for which you would like to visualize the spoke and activate it via the show check box. The
parameter in the tabel define the attributes of the Spoke: Color, Name, Bias, Length (of the largest
value), and whether the values should be interpreted relatively. The parameter for the spokes renderer
are Style, Angle, Width, Length, Distance. Note: To arrange the spokes in the Circular layout click
the symbol for circular layout again after setting up all the parameter of the Spoke Renderer.

8.2.1.5 Minimal Renderer
The Minimal Renderer renders both nodes and edges using very primitive calls to OpenGL. The
resulting visualization is less detailed than any of the other renderers, but uses fewer resources and is
more responsive for large graphs.
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8.2.2 Workspace
The workspace provides a concise visual summary of all of the nodes, edges, attributes and graph
data in list format.

8.2.2.1 Graph
Allows exploration of the data model.

8.2.2.2 Nodes
Lists node types and respective object count.

8.2.2.3 Edges
Lists edge types and respective object count.

8.2.2.4 Attributes
Lists attributes with info on their types.

8.2.2.5 Graph Data
Lists graph data entries; options to delete graph data and restore OGLGraphView.

8.2.3 Documentation
The documentation tab provides a space to log your own notes, and a space that automatically saves
your steps performed while working with a network (example, addition of rendering layers).

8.2.4 Layout
The layout space allows you to add various types of layouts to your graphs. It provides a space to
track, modify and delete your layouts. Options include: static layouts (weighted grip, spoke, grip),
dynamic layouts (projector, grid, force directed, attractor). Further details in Chapter 4.

8.2.5 Subsets
Subsets are groups of graph objects that are saved and labeled with a parent node. These are useful
in creating logical groupings within your graph, and essential to creating hierarchical graphs, such
as those used in BioPAX and KGML files. When a subset is created, a parent node is created
by default. This node is used within hierarchical graphs to represent the subset. For example, if
node A interacts with a complex containing nodes B and C, an edge could be used to represent this
interaction connecting A to the parent node of the subset containing B and C. Parent nodes can be of
any node type, and can have any attributes associated with that node type within spreadsheets and
tables, their data is treated exactly the same as any other node. Subsets are generated by some file
imports and can also be created and manipulated using the Subsets Tab.

8.2.6 Selection
For the highlighted portion of the graph, the selection space contains a table with the OID value,the
type of node/edge, and the label number.

Changing settings within each rendering layer alters the visual properties of the objects rendered
in the OpenGL Graph View. The objects affected by the changes are defined in the settings menu,
accessible through the gear icon in the top right corner of the layers view. Based on the currently
selected objects in the current OpenGL Graph View, you can change the settings for the selection,
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the inverse of the selection, or the whole graph, depending on which option is selected from the
menu.

Each rendering layer controls how the selection appears in the OpenGL graph, by outlining or
otherwise indicating the objects selected. You can set the color used to do this by clicking on the
’Choose Selection Color...’ item in the settings menu. In addition, the temporary selection color can
also be set using the ’Choose Temporary Selection Color...’ item.

8.2.7 Search

The search bar allows you to perform an attribute search, OBO search or XML search. It also
provides the OID value and node/edge type when you input a label number into the search bar.

8.2.7.1 Attribute Search

Allows to search for nodes using any attribute. Selecting the type of object the attribute refers
to will open a drop-down menu to select the attribute of choice. The choices for search include
between, equal, greater or greater and equal than, less or less and equal than a value of choice
for quantitative attributes. Once selected what to search for, the amount of reference needs to
be specified. For qualitative attributes, it is possible to choose among equal, not equal, like, like
case insensitive and regular expression. Some examples of regular expressions can be found at
http://www.regular-expressions.info/posix.html. Once selected what to search for, it is
important to specify the character that separate the texts being searched for.

8.2.7.2 OBO Search

The OBO Ontology tab is designed to browse Open Biomedical Ontology data.
The table on the left side of the tab shows the current selection of graph objects. If they contain

OBO ontology information, obtainable using the ’UniProt Annotations...’ database query, the relevant
IDs will be displayed in a list on the right side of the tab.

8.2.8 Analysis

The analysis space allows you to visualize (and select) various graph features including the shortest
path between source and target nodes, bioconnected components, and intersubset edges and shortest
paths. It can also calculate attribute statistics, and provides an RMW Finder with which you can
easily view the regulators, managers and worhorses on your graph. Further details in Chapter 5.

8.2.8.1 Bioconnected Components

Identifies maximal biconnected subgraphs.

8.2.8.2 RMW Finder

Identifies regulators, managers, workhorses in a graph.

8.2.9 Console

The console tab allows the user to view text feedback from the workspace, as well as execute console
commands.

Text can come from individual graphs available in the Workspace, as well as from the workspace
itself. Likewise written commands can be executed for the workspace or for individual graphs.

http://www.regular-expressions.info/posix.html
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8.3 Layout Panels
The layout panels provide allow you to add, track and edit a variety of static and dynamic layouts on
your graph.

8.3.1 Sorting
Allows you to sort nodes according to any attribute. Further details in Chapter 4.

8.3.2 Graph Layout
It lays out nodes and edges in an automatic way. Further details in Chapter 4.

8.3.3 Spreadsheet
A tabular visualization of all the data associated to the graph. Further details in Chapter 4.

8.3.4 Matrix Layout
A graph visualization where node to node relationships are shown as cells of a matrix where each
row and each column represents a node. Further details in Chapter 4.

8.3.5 Serial Data Layout
This view summarizes repeated measurements for the same attribute for each node. Further details
in Chapter 4.

8.3.6 Bar Chart
This graph view displays graph attributes in a bar chart format. There are three tabs in this view, one
each for Nodes, Edges, and Subsets, which can be selected in the lower left of the view. Further
details in Chapter 4.



9. Frequently Asked Questions

This chapter contains frequently asked questions with links to the corresponding section
in the manual.

a. How do I create a new network?
Please refer to Section1.4

b. Is it possible to merge networks?
Yes, it is. Please refer to Section2.4.2

c. How do I change the color of the nodes in a sub-network?
Please refer to Section3.5

d. How do I find connected components?
Please refer to Section5.3.3





Glossary

Annotation Assigning values to an object. 25
APSP All Pairs of Shortest Paths. 46
Attribute Values associated with graph objects. 13, 26, 45, 47

BioModels Networks repository. 17
BioPAX Biological Pathway Data. 14
Boolean Binary variable that can be either true or false. 13

DEX Standard file format and previous name of Sparksee. 14, 23
Double Numeric variable that can represent continuous numbers (floating-point decimal). 14

Edge Edges or interactions, connect the objects in a network. 6, 8, 46, 48, 65

Global Applying to all objects in a graph. 13
GO Gene Ontology. 16, 27, 47
graph The network itself. 6
GraphML Graph format based on XML. 16, 23

IID Integrated Interaction Database. 26, 53
Integer Numeric variable that can represent discrete numbers (a 32-bit whole number). 13

KEGG Pathways repository. 17
KGML KEGG Markup Language. 16

Linux Linux is a family of free and open-source software operating systems. 6
Long Numeric variable that can represent discrete numbers (a 64-bit whole number). 14

Microsoft Windows Microsoft Windows is a family of graphical operating systems developed and
marketed by Microsoft. 6

.n3e NAViGaTOR 3 file format. 16, 22
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Node Nodes or vertices are representing the objects of a network. 6, 8, 45, 64

OBO Open Biological and Biomedical Ontology. 16
OID Object Identifier for Graph Objects. 14

PathDIP Database for pathway enrichment analysis. 26
PSI-MI Proteomics Standards Initiative - Molecular Interaction. 16

random network A random network consists of randomly generated notes and edges. 8
Renderer Rendering or plotting the nodes, labels and edges on the graph canvas. 64, 65

SBML Systems Biology Markup Language. 16
serial Repeated attributes for the same element. 19
Sparksee NAViGaTOR backbone graph database. 13
String Variable that can store short text’s or words (up to 2048 characters) Optimal for attributes

like categories. 14
Subset Sub-graph. 11, 19, 27, 45, 48

Tab-delimited file A tab-delimited file is a text file with a table like structure Each row is represented
by on line in the file and the columns in a line separate the columns. 14, 15, 18, 23, 54

Text Variable that can store long texts (up to and beyond 2048 characters). 14
Timestamp Variable that represents dates or times Required for time series data. 14
Type A type is a named category that an object, such as node, edge, or attribute belongs to. 7, 13, 15

XGMML eXtensible Graph Markup and Modelling Language. 16, 23
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